TA: Kingdoms Community Forum
 
HomePortalCalendarGalleryFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 Crash\Bug reports

View previous topic View next topic Go down 
Go to page : 1, 2  Next
AuthorMessage
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: CrashBug reports   Wed Oct 09, 2013 12:02 pm

Hello everybody. I am new here, and i totally like this mod, as it brings a new life into game of my childhood. Howewer i face a lot of crashes while playing it. And when i came here i've not seen crash\Bug reports thread. So i decided to create it. I will put here info about crashes and bugs, trying to be as detailed is possible. Hope it will help to improve the mod. (sry if my english is bad)


Last edited by T-1000 on Wed Oct 09, 2013 12:09 pm; edited 1 time in total
Back to top Go down
View user profile
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Re: Crash\Bug reports   Wed Oct 09, 2013 12:07 pm

So here is the first one: i used creon "wheel warriors" to harass taros base. i got lucky, being able to easily destroy pair of dark massons and lodestones. And as soon as wheel warrior had to get his rank up the game crashed. Mod version is 4.2. My OC is Windows 7.
Back to top Go down
View user profile
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Fri Oct 11, 2013 9:20 pm

The game did drop when one of the wheel warriors killed the other monarch.

I noticed there was a missing texture in the model; however, it had nothing to do with veterancy change.

This is what the script file looks like:

script:
 


Does anyone see something wrong? All 5 veteran objects do not exist in the 3do model, but they are there using a transparency texture. So when the script calls these non-existing objects, could it be that it's crashing the game because of this?

RESOLVED: Thanks for the feedback T-1000. Adding the missing texture did fix the problem, even though it wasn't veteran related.

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Wed Oct 16, 2013 7:27 pm

NewEra 5.0 is coming soon, so come post any issues that you may have had encounter before 5.0 gets released. As I have stated before, the mod will come with 2 anti-hacks, one for the gamespeed, and the other for the unit stats. Any requests come post them here. Finally, there is a big change in the tier structure compared to v4.2. You'll notice some units changed to other tiers, resized and rebalanced, and the removal of a few others.

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935


Last edited by Sage on Wed Oct 16, 2013 11:39 pm; edited 1 time in total
Back to top Go down
View user profile http://cristian-fuentealba.com
$_ARTHAN

avatar

Posts : 765
Reputation : 2
Join date : 2011-03-01
Age : 27
Location : Greece

PostSubject: Re: Crash\Bug reports   Wed Oct 16, 2013 7:45 pm

I am actually looking forward to the anti-hack feature.
Back to top Go down
View user profile
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Re: Crash\Bug reports   Thu Oct 31, 2013 6:33 am

Another one - same problem with "kodbold slave" of zhon.
Back to top Go down
View user profile
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Re: Crash\Bug reports   Thu Oct 31, 2013 7:00 am

Also - wacker. It does not make the game crash but the unit itself have huge problems withh attacking anything. I checked it several times - it does damage (a bit. Sometimes.) but have no attack animation and most of the time in battle it just stand still and do nothing.
Back to top Go down
View user profile
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Thu Oct 31, 2013 3:31 pm

I'm pretty sure I checked the kobold slave for that issue, but I'll double check on it. Was this for 4.2?
The wacker made the game crash for me in 4.2 when it became veteran after killing a monarch; that issue is fixed.

To add the attack animation on the wacker is on the to do list in the structure section. The wheel is supposed to be spinning while attacking as it being the weapon.

NewEra 5.0 has been released!

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Re: Crash\Bug reports   Thu Oct 31, 2013 6:21 pm

(about kodbold issue) Yep it was 4.2 version.
Back to top Go down
View user profile
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Angelic crush   Sun Nov 10, 2013 6:02 am

So i've updated mod to 5.0 version and here comes a brand new crash. It happens when i controll angel-like flying units (aramon angels; fallen angel; veruna angel), and order them to rapidly change their direction. ( something about 180+/- 30 degree) Happens in something about 70% of cases.

P.S. (Sry if my english is bad)
Back to top Go down
View user profile
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Mon Nov 11, 2013 10:47 pm

What was the problem with the kobold slave? Was it making the game crash when become veteran?
I'll looked into it, and couldn't find any issues with the unit. Manolo or Vaerun, do you see anything wrong with this unit?

zonorckobold - kobold slave

I also tested the angels for a while, and could not get the game to drop. Perhaps you had broken units from other races that made the game crash at a particular point.

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
DeeKay
Administrator
avatar

Posts : 513
Reputation : 28
Join date : 2011-03-19
Age : 18
Location : Brazil - SP

PostSubject: Re: Crash\Bug reports   Tue Nov 12, 2013 7:29 am

I think I found the issue:



The problem is that veteran shoulders are filled with nothingatall texture, and they don't have model? wtf I didn't understand much... Spear and Spear_10 are also with nothingatall texture and don't have models.

I tried to copy others models and put other textures and it worked. Very Happy
No problems in tdf nor in .cob.

_________________


Nick: DeeKay
GameRanger Account ID: 1184157
E-mail (Skype, Outlook and Facebook): Henrique-MS@Outlook.com
All TA:K Downloads Youtube Channel: http://www.youtube.com/AllTAKDownloads
All TA:K Downloads Facebook Page: https://www.facebook.com/AllTAKDownloads

Back to top Go down
View user profile http://alltakdownloads.6te.net/
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Tue Nov 12, 2013 2:07 pm

The kobold slave did not make the game drop for me when it became veteran. The game should not drop if an object is filled with the nothingatall texture. When an object has a missing texture, then the game drops, so we add the nothingatall texture to fill that emptiness in the unit. Therefore, I do not think this is the issue.

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
DeeKay
Administrator
avatar

Posts : 513
Reputation : 28
Join date : 2011-03-19
Age : 18
Location : Brazil - SP

PostSubject: Re: Crash\Bug reports   Tue Nov 12, 2013 5:42 pm

Yes it did for me first time (running 5.0 version), so I fixed the models/textures and it worked...

_________________


Nick: DeeKay
GameRanger Account ID: 1184157
E-mail (Skype, Outlook and Facebook): Henrique-MS@Outlook.com
All TA:K Downloads Youtube Channel: http://www.youtube.com/AllTAKDownloads
All TA:K Downloads Facebook Page: https://www.facebook.com/AllTAKDownloads

Back to top Go down
View user profile http://alltakdownloads.6te.net/
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Thu Nov 14, 2013 9:12 pm

Do you still have the file that fixed the issue? Can you send it to me?

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
Necrohands



Posts : 3
Reputation : 0
Join date : 2013-11-17
Location : Milton Keynes, UK.

PostSubject: Re: Crash\Bug reports   Sun Nov 17, 2013 8:34 am

I'm not entirely sure how helpful my error reporting will be, but i'm using 5.0 on Win 7 Home 32-Bit and the game has been quite unstable.

Ive had crashes with saving, crashes loading maps, characters disappearing and a few others.

I'll keep note of whatever issues I run into. What information do you need?
Back to top Go down
View user profile
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Sun Nov 17, 2013 2:36 pm

Necrohands wrote:
I'm not entirely sure how helpful my error reporting will be, but i'm using 5.0 on Win 7 Home 32-Bit and the game has been quite unstable.

Ive had crashes with saving, crashes loading maps, characters disappearing and a few others.

I'll keep note of whatever issues I run into. What information do you need?
This is the first time I get this type of feedback. When it crashed, what maps were loading? What characters disappeared? At what point were you saving the game, what was the time? You mentioned "and a few others", could you be more specific on what you referred to?

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
$ MalinOMW

avatar

Posts : 576
Reputation : 10
Join date : 2011-07-22
Age : 24
Location : Poland

PostSubject: Re: Crash\Bug reports   Sun Nov 17, 2013 3:44 pm

and game crash only with new era? or with normal TA:K too

(thats global crashes sounds more like TA:K<->PC problems, than just by mod)

_________________
https://www.youtube.com/user/OfficialAkcent
Back to top Go down
View user profile
Necrohands



Posts : 3
Reputation : 0
Join date : 2013-11-17
Location : Milton Keynes, UK.

PostSubject: Re: Crash\Bug reports   Sun Nov 17, 2013 6:16 pm

$ MalinOMW wrote:
and game crash only with new era? or with normal TA:K too

(thats global crashes sounds more like TA:K<->PC problems, than just by mod)
I can remember only vaguely, but i've got TA:K Iron Plague + the New Era mod.

I'll check the map name when i get a chance tomorrow, but its happening on a multitude of them and its not consistent.

The frozen unit was a Flying Builder from Aramon. I could click, but all of its information had disappeared, the unit was frozen and couldn't move etc.

The game is randomly crashing at points during the game and freezing up. Not sure if that is an issue on my end. It can happen when loading maps, when mid-game, saving game...

No crashes prior to new era...ever.
Back to top Go down
View user profile
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Sun Nov 17, 2013 6:26 pm

That's very strange. The only flying builder from aramon is the flying builder, and that unit cannot be frozen according to the game stats and NewEras'. Perhaps, your game has become corrupt somehow. If you did everything that is on the "How To Play" text file, then you shouldn't have any problems. It also could be a coincidence that your game is crashing now, and those problems that you described sound like issues with windows. I would recommend to test your HDD and RAM, then boot into safe mode and ran a virus check. If everything I mentioned is correct, then I would try reinstalling the game with the 4.1bb patch.

P.S. Not all problems with a computer can be software related.

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
Necrohands



Posts : 3
Reputation : 0
Join date : 2013-11-17
Location : Milton Keynes, UK.

PostSubject: Re: Crash\Bug reports   Mon Nov 18, 2013 8:58 am

Yeah, the hardware on the PC is fine. I run checks quite regularly and ive suffered no issues with performance elsewhere.

I'm assuming i've somehow corrupted the game. I'll try a clean install and re-install the mod. I followed the instructions but i'll try it all again and report back.

Not entirely sure if the model for the flying builder was considered to still be alive. I think it had been killed maybe, but not sure why the model stayed there.

I'll report back on any issues i'm having and see where i'm going wrong.
Back to top Go down
View user profile
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Re: Crash\Bug reports   Mon Dec 02, 2013 5:22 pm

farao dat feel when u created livivng thread XD. Returning to bugs - angel-crush never repeated when was cheking it. Guess something different cause this. I dont have a lot of free time this month but if ill find something - ill post it.
Back to top Go down
View user profile
Sage
Lead Designer of Ta Kingdoms: The New Era
avatar

Posts : 1034
Reputation : 3
Join date : 2008-08-02
Age : 30
Location : West Haven

PostSubject: Re: Crash\Bug reports   Sat Dec 07, 2013 10:39 pm

Cool, thanks for the report.

_________________
http://takuniverse.webs.com/ - TAK downloads
www.cristian-fuentealba.com - Graphic Design
GameRanger ID: 4138935
Back to top Go down
View user profile http://cristian-fuentealba.com
T-1000



Posts : 8
Reputation : 0
Join date : 2013-10-09
Age : 26
Location : Russia

PostSubject: Re: Crash\Bug reports   Wed Feb 26, 2014 4:19 pm

Reporting new crash - game crashed during neo dragon's attempt on freexing chariot warrior. Will experiment with them tomorrow to be 100% sure. Not sure was that one with spear or bow. There is more but im not sure about conditions.
Back to top Go down
View user profile
Tasuh



Posts : 2
Reputation : 0
Join date : 2013-08-02

PostSubject: Re: Crash\Bug reports   Mon Apr 21, 2014 6:25 am

Since you all seem to be on the NewEra 5.0 I was wondering for the Creon Unit Aegis Tower if it's working for anyone? When I build it; it doesn't move, rotate, or seem to attack. I know in the NE 3.9 the Prismatic Mirror did the same thing but they seem to be working now.

Sage I finally got NE 5.0 to finally download took about 4 hours (I only have dial-up Internet for anyone wondering why it took so long for me to download it) I just paused the download then resumed it a few times during the whole download.

Using TAK switcher BB patch 4.1 NewEra 5.0 Tabnar's Terrance Map
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Crash\Bug reports   

Back to top Go down
 
Crash\Bug reports
View previous topic View next topic Back to top 
Page 1 of 2Go to page : 1, 2  Next
 Similar topics
-
» Game crash
» Pictures in the battle reports ?
» 2 Battle Reports, 1 Thread
» Giorgio Bartocci crash....Safety belt failure
» Crash Teams

Permissions in this forum:You cannot reply to topics in this forum
TA: Kingdoms Community Forum :: MODS & 3RD PARTY :: The NewEra Expansion Project :: Bugs and Balance Issues-
Jump to: